سلام دوستان سوالی که امروز براتون انتخاب کردم یه سوال از مسابقه DM Contest سایت Sharecode.ir هستش که چند هفته پیش برگذار شد منبع اصلیش   Mid-Atlantic 2004 هستش ... این مسئله خیلی وقت منو گرفت چون هربار سعی کردم جواب بهتری واسش ارائه بدم ... در آخر هم از سایت ShareCode.ir و سایت poj.org واسه این راه حل Accept گرفتم ولی سایت ICPC Live Archive به کد Wrong Answer داد .

خب ابتدا سوال رو مطالعه کنید

Description

You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought. Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.

Input

Only one town will be given in an input.
  • The first line gives the length of cable on the spool as a real number.
  • The second line contains the number of houses, N
  • The next N lines give the name of each house's owner. Each name consists of up to 20 characters {a–z,A–Z,0–9} and contains no whitespace or punctuation.
  • Next line: M, number of paths between houses
  • next M lines in the form

< house name A > < house name B > < distance >
Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.

Output

The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output
Not enough cable
If there is enough cable, then output
Need < X > miles of cable
Print X to the nearest tenth of a mile (0.1).

Sample Input

100.0
4
Jones
Smiths
Howards
Wangs
5
Jones Smiths 2.0
Jones Howards 4.2
Jones Wangs 6.7
Howards Wangs 4.0
Smiths Wangs 10.0

Sample Output

Need 10.2 miles of cable
این مسئله در واقع چیزی نیست جز زیر درخت پوشای مینیمم minimum spanning tree برای گراف که من برای حل از الگوریتم پریم    Prim's algorithm  ( چون پیاده سازی راحت تر و سرعت به نسبت بیشتری داره ) استفاده کردم همچنین از یه ساخمان داده به اسم Map استفاده کردم که ساختمان داده خیلی بدرد بخوری هستش .. شما میتونید یک کلاس رو به عنوان index و کلاس دیگری رو به عنوان محتوی استفاده کنید ... که من اینجا برای تبدیل اسم افراد به یک عدد توی ماتریس مجاورتم استفاده کردم ... بعدشم که درواقع همون پیاده سازی الگوریتم پریم بود.
هرکدوم از دوستان اشکال کد من رو که توی ICPC Live Archive نتونست Accept بگیره رو پیدا کرد خیلی ممنون میشم .
موفق باشید.


#include<iostream>
#include<iomanip>
#include<string>
#include<cstring>
#include<map>
using namespace std;
int mV,N;
bool Visited[1000];
float R[1000][1000],mW;
void FindMin(){
    int i,j;
    for(i=0;i<N;i++){
        if(Visited[i]){
            for(j=0;j<N;j++){
                if(Visited[j])continue; 
                if(R[j][i]){   
                if(mW==-1||R[j][i]<mW){

                        mV=j;

                        mW=R[j][i]; }   }

            }

        }

    }

}

int main(){

map<string,int> sm;

string st1,st2;

float HaveCable,NeedCable=0,tl;

int i,M,ID1,ID2;

cin>>HaveCable>>N;

for(i=0;i<N;i++){

cin>>st1;

sm[st1]=i;

}

memset(R,0,sizeof(R));

memset(Visited,0,sizeof(Visited));

cin>>M;

for(i=0;i<M;i++){

cin>>st1>>st2>>tl;

ID1=sm[st1];

ID2=sm[st2];

R[ID1][ID2]=R[ID2][ID1]=tl;

}

Visited[0]=1;

mW=-1;

for(i=0;i<N-1;i++){ FindMin();

       NeedCable+=mW;

       Visited[mV]=1;

       mW=-1;

}

if(NeedCable>HaveCable){ cout<<"Not enough cable\n";

}else{ cout<<"Need "<<fixed<<setprecision(1)<<NeedCable<<" miles of cable\n";

}

return 0;

}